Alors que la version 4.5 de WordPress n’a qu’une petite dizaine de jours, l’équipe de développement a annoncé que WordPress 4.5.1 allait être mis en test pour une Release Candidate. Qu’en est-il de cette mise à jour, pourquoi si tôt? Je vais tenter de faire la lumière.

WordPress 4.5.1 – Objectif : Corriger les erreurs

WordPress 4.5.1 - Objectif : Corriger les erreurs

Cette nouvelle version va être disponible assez rapidement, car certains utilisateurs ont des problèmes assez sérieux depuis la mise à jour vers WordPress 4.5.

Voici quelques unes des erreurs qui devraient être corrigées par la mise à jour. Les données entre parenthèses (#36xxx) correspondent au numéros de tickets signalant l’erreur.

  • La version RC va servir à tester les modifications apportées à TinyMCE qui, lorsqu’il est utilisé avec Chrome version 50.0.2661.75 beta-m (64-bits), ne fonctionne pas correctement. Ainsi, si l’on clique sur l’onglet Texte pour modifier le code source, il est impossible d’utiliser certaines options de la barre d’outils. En cliquant sur l’onglet Texte ou en cliquant sur la barre d’outils ces options aboutissent des erreurs. (#36545)
  • Deuxième erreur qui devrait être corrigée dans WordPress 4.5.1, les pages avec widget du thème Twenty Eleven sont mal stylisées. Les widgets ne fonctionnent plus dans la barre latérale, et sont poussés vers le bas le long du côté droit, sous le contenu du message. (#36510)
  • Troisième problème devant être corrigé, dans certains cas, la bibliothèque de médias n’affiche rien. Cette erreur semble dûe à jQuery version 1.12.0 inclus dans WordPress, alors qu’avec la dernière mise à jour de jQuery version 1.12.3, deux lignes de code CSS sont mal interprétées, bloquant l’affiche de la bibliothèque de médias. (#36533)
  • Le problème suivant que devrait résoudre la version à venir provient de la fonction POST['nav-menu-data'] qui modifie certaines valeurs dans la page. L’explication étant très technique, je vous en fait cadeau. (#36590)
  • Autre erreur constatée, la duplication de directives dans web.config empêche l’affichage de la page d’accueil ou de la page de connexion WordPress après l’installation de la version 4.5, générant une erreur 500. (#36506)
  • Enfin pour terminer, une erreur de codage dans TinyMCE (#36578) génère un bug dans l’éditeur d’article.

Selon les données communiquées par l’équipe de développement, WordPress 4.5.1 devrait, sauf problèmes, être disponibles dans les tous prochains jours.

BRANDT Valentin

J'ai travaillé dans l'informatique pendant près de 30 ans. De la formation, la maintenance, le développement, et le management, j'ai touché à presque tous les domaines. Maintenant que je ne travaille plus, je m'intéresse avant tout à Wordpress et Android.

Ne manquez pas nos autres contenus :