Une vulnérabilité a été découverte la semaine passée dans le plugin Akismet, et compte tenu qu’Akismet est un des plugins les plus utilisés pour WordPress, j’ai tenu à vous apporter quelques explications.

Akismet est un filtre anti-spam pour les commentaires de WordPress, et en général, il fait un excellent travail. L’équipe d’Akismet a annoncé, sur son blog la semaine passée, qu’une vulnérabilité de type Cross Site Scripting (XSS) avait été découverte dans toutes les versions d’Akismet, depuis la version 2.5.0.

La vulnérabilité permet à un attaquant de poster un commentaire sur un site WordPress. Ce commentaire va exécuter un code JavaScript dans la console d’administration de WordPress. C’est un cas typique de la vulnérabilité XSS et l’une des attaques qui permettrait à un attaquant de voler les cookies d’un administrateur WordPress et d’obtenir un accès administratif à un site WordPress.

Il n’y a aucune preuve que la vulnérabilité a été exploitée à l’heure actuelle. Les équipes Akismet et WordPress ont immédiatement pris les mesures suivantes:

[su_list icon= »icon: check-circle-o » icon_color= »#2d89ef »]

  • Publication de mises à jour pour toutes les versions affectées.
  • L’équipe de WordPress.org a publié une mise à jour automatique du plugin Akismet sur les sites touchés. Si vous avez remarqué que votre site WordPress a été automatiquement mis à niveau vers la dernière version d’Akismet, vous avez à présent l’explication.
  • L’équipe Akismet a modifié son API de sorte que, si un pirate a essayé d’exploiter une version vulnérable d’Akismet, leur API bloquerait l’attaque en filtrant le commentaire que le pirate a tenté de poster. Cela signifie que dès que la vulnérabilité a été découverte et que l’équipe Akismet a mis en place les modifications, même les versions vulnérables d’Akismet ne sont plus exploitables.

[/su_list]

Bravo a l’équipe Askimet pour leur réactivité!

Alerte de sécurité WordPress – 20-10-2015

Nous vous informons régulièrement des problèmes de sécurité liés au monde WordPress, core, thème et plugin, ne passez pas à côté de l’information qui vous pourrait être vitale.

[Tweet « Failles de sécurité détectées dans 7 plugin WordPress »]

WordPress Gwolle Guestbook – Exécution de code

[alert-note]Un attaquant peut écrire arbitrairement des données dans un fichier et exécuter le code entré sans que l’administrateur soit averti[/alert-note]

WordPress Akismet : Cross Site Scripting

[alert-note]Faille corrigée dans la version 3.1.5 – Veillez à faire la mise à jour immédiatement.[/alert-note]

WP-Piwik version <= 1.0.4

[alert-note]Faille corrigée dans la version 1.0.5 – Veillez à faire la mise à jour immédiatement.[/alert-note]

Events Made Easy version <=1.5.49 – Plusieurs Cross Site Scripting & Cross Site Request Forgery

[alert-note]Faille corrigée dans la version 1.5.5.0 – Veillez à faire la mise à jour immédiatement.[/alert-note]

WordPress WP REST API : Cross Site Scripting

[alert-note]Le cross-site scripting (abrégé XSS), est un type de faille de sécurité des sites web permettant d’injecter du contenu dans une page, permettant ainsi de provoquer des actions sur les navigateurs web visitant la page[/alert-note]

WordPress Tag Miner – Cross Site Scripting

WordPress Ajax Load More Plugin version< 2.8.2 – Téléchargement arbitraire de fichiers

[alert-note]Faiblesses dans la gestion des autorisations, privilèges, et autres fonctions de sécurité utilisés pour le contrôle d’accès aux fichiers permettant à un attaquant de télécharger un fichier à risque sur le serveur.[/alert-note]

Sécurité WordPress

[Tweet « Vulnérabilités découvertes dans 7 plugin WordPress »]

Aucune faille n’est bénigne, et malgré le suivi que vous apportez à vos sites WordPress, votre site est à risque si vous ne prenez pas les mesures appropriées. Vous ne laisseriez pas la porte de votre domicile ouverte en partant, alors faites de même avec votre site WordPress, sécurisez le.

Ne pensez pas que cela n’arrive qu’aux autres, tous les sites WordPress sont concernés par les problèmes de sécurité!

Conseils pour sécuriser votre site

      • Ne pas utiliser “admin” comme identifiant administrateur
      • Faites attention à ce que vous téléchargez
      • Mettez à jour WordPress
      • Mettez à jour vos thèmes et plugin
      • Utilisez un mot de passe fort
      • Limitez le nombre de tentatives de connexion avec Login LockDown
      • Faites des sauvegardes régulières de la totalité de votre site avec BackupBuddy
      • Utilisez au moins un plugin de sécurisation tel que iThemes Security

Rappel important!

Une sauvegarde régulière de la totalité de votre site WordPress (base de données, thèmes, et plugin) est nécessaire afin de palier à tout problème.

séparateur de texte

 La sécurité est l’affaire de tous, dans l’intérêt de tout le monde, Partagez cet article, Merci!

BRANDT Valentin

J'ai travaillé dans l'informatique pendant près de 30 ans. De la formation, la maintenance, le développement, et le management, j'ai touché à presque tous les domaines. Maintenant que je ne travaille plus, je m'intéresse avant tout à Wordpress et Android.

Ne manquez pas nos autres contenus :